Deutsche Bank instability affecting PIS traffic and payment reconciliation

Incident Report for Mastercard OB Services EU and UK

Resolved

Via internal monitoring we have detected a increase in failed PIS requests that affected payment reconciliation.
Deutsche Bank has confirmed there was an issue on their PSD2 APIs and it is now resolved.

Their communication:

PSD2 APIs – The below mentioned issue is now resolved and payments are now processing fine from our end.

Issue Time Window :

Start Time - 17-Feb-26 19:10 CET
End Time - 17-Feb-26 21:00 CET
Posted Feb 17, 2026 - 18:00 UTC