DNB Payment Initiation Service issue

Incident Report for Mastercard OB Services EU and UK

Resolved

DNB's Payment Initiation Service API was affected by the incident.

Reported at: August 24, 2026, 14:04 GMT +02:00
Resolved at: August 24, 2026, 14:19 GMT +02:00
Posted Aug 24, 2026 - 10:04 UTC