Outage on all call types with BEC based providers in Denmark and Greenland

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Sep 24, 2023 - 13:55 UTC

Investigating

We are experiencing an outage with BEC based providers in Denmark and Greenland. All call types are affected.
Posted Sep 24, 2023 - 09:07 UTC
This incident affected: Providers (Denmark).