Issues with Instant Payments for Danske Bank Business in Finland

Incident Report for Mastercard OB Services EU and UK

Update

We are continuing to investigate this issue.
Posted Feb 17, 2026 - 15:19 UTC

Investigating

We have identified an issue with instant payment initiation in Danske Bank Business Finland.

We are working on a solution
Posted Feb 17, 2026 - 15:03 UTC
This incident affects: Providers (Finland).