Elevated error rates on all call types with Nordea, Nordea Erhverv, Nordea Yrityspankki and Nordea Företag in Norway, Denmark, Finland and Sweden
Incident Report for Aiia
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 07:51 UTC
Investigating
We are seeing elevated error rates affecting most calls with Nordea, Nordea Erhverv, Nordea Yrityspankki and Nordea Företag in Norway, Denmark, Finland and Sweden. All call types are affected.
Posted Apr 11, 2024 - 06:12 UTC
This incident affected: Providers (Denmark, Norway, Finland).