Elevated error rates affecting PSD2 services in Lithuania for Luminor

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 10:57 UTC

Investigating

We are currently experiencing issues with Luminor psd2 openbanking services in Lithuania. Issue started ~ 15:30 EET. We are investigating the root cause.
Posted Apr 08, 2026 - 14:49 UTC
This incident affected: Providers (Lithuania).