Luminor maintenance activities for Lithuania

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 11:07 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 08, 2025 - 10:48 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 07, 2025 - 20:45 UTC

Monitoring

Maintenance is taking a place between 20:00 UTC - 22:30 UTC, which might cause instability and/or downtime.
Posted Jul 07, 2025 - 20:45 UTC
This incident affected: Providers (Lithuania).