Maintenance of the Nordea integration

Scheduled for Oct 27, 07:15 UTC  -  Oct 31, 07:15 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Oct 24, 2025 - 12:40 UTC

Scheduled

We will be performing scheduled maintenance on our integration with Nordea to ensure continued stability and performance. The maintenance window is as follows:

🛠️ Start Time: 27th of October [Morning]
🛠️ End Time: 30th of October [Afternoon]

If you encounter any issues or have questions, please reach out to our customer service.
Posted Oct 24, 2025 - 12:39 UTC
This scheduled maintenance affects: Providers (Denmark, Sweden, Norway, Finland).