Payment creation issues

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 07:48 UTC

Investigating

We are observing issues with payment creation on SEPA Instant rails and are investigating.
Posted Sep 09, 2026 - 07:41 UTC
This incident affected: Payment Products (Accept Payments).