Observing issue with Swedbank

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Aug 09, 2026 - 09:46 UTC

Investigating

We are currently observing an issue with Swedbank's web site. The bank's website appears to be unavailable, which may impact Open Banking connectivity and related services for Swedbank customers.
Our platform is operating normally, and we are actively reaching out to Swedbank to obtain additional information regarding the incident and expected resolution timeline.
Updates will be provided as they become available.
Posted Aug 08, 2026 - 09:26 UTC
This incident affected: Providers (Sweden, Estonia, Latvia, Lithuania).