Issues with MitId in Denmark

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 08:22 UTC

Monitoring

Seems like the issue is resolved and MitId is working again, but we're continuing to monitor for any further issues
Posted Nov 18, 2025 - 10:09 UTC

Investigating

We are seeing issues with the MitId identity provider in Denmark
Posted Nov 18, 2025 - 10:02 UTC
This incident affected: Providers (Denmark).