Elevated failed payment rate with Nordea and Nordea Yrityspankki in Denmark, Norway and Finland

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 13:16 UTC

Investigating

We see elevated rates of failed payments with some users affected on Nordea and Nordea Yrityspankki in Denmark, Norway and Finland.
Posted Jun 02, 2025 - 12:36 UTC
This incident affected: Providers (Denmark, Norway, Finland).