Decreased conversion rate for Deutsche Kredit Bank

Incident Report for Mastercard OB Services EU and UK

Resolved

We haven't seen any new error in the last hours, resolving the incident now
Posted Jun 25, 2026 - 19:37 UTC

Update

We continue monitoring, haven't observed any failed payment in the last two hours
Posted Jun 25, 2026 - 13:17 UTC

Monitoring

Starting at 12:30 CEST, we are observing successful traffic. Will continue monitoring
Posted Jun 25, 2026 - 10:42 UTC

Investigating

Since yesterday 2026-06-24 afternoon we have observed a drop in conversion rate for Deutsche Kreditbank
We are currently investigating
Posted Jun 25, 2026 - 08:03 UTC
This incident affected: Providers (Germany).