Intermittent Access Issues

Incident Report for Mastercard OB Services EU and UK

Resolved

The issue affecting access to OpenFinance APIs has been resolved. Service availability has been restored, and we are continuing to monitor performance to ensure stability.

Impact window: 06:10 AM UTC – 06:26 AM UTC
Posted Mar 25, 2026 - 07:32 UTC

Investigating

We are aware of an issue impacting access to OpenFinance APIs. Some customers may be unable to connect, or may experience intermittent errors and timeouts.

Our team is working to identify the cause and restore normal access as quickly as possible.
Posted Mar 25, 2026 - 06:47 UTC
This incident affected: Payment Products (Accept Payment) and Connect Flows (Aiia Connect Flows).