Disruption with OP Financial Group PSD2 APIs

Incident Report for Mastercard OB Services EU and UK

Resolved

We have noticed a service disruption affecting OP's PSD2 APIS. OP PSD2 API users may experience issues. Our specialists are investigating the problem. We apologise for any inconvenience caused by the disruption.
Posted Aug 20, 2025 - 14:10 UTC

Monitoring

We have noticed a service disruption affecting OP's PSD2 APIS. OP PSD2 API users may experience issues. Our specialists are investigating the problem. We apologise for any inconvenience caused by the disruption.
Posted Aug 20, 2025 - 13:43 UTC