Outage on Millenium

Incident Report for Mastercard OB Services EU and UK

Resolved

Connectivity has been restored
Posted Apr 21, 2026 - 07:56 UTC

Investigating

We have identified an outage on Millennium bank. All requests are affected
Posted Apr 21, 2026 - 06:25 UTC
This incident affected: Providers (Poland).