Failed payments observed on European Payment Platform

Incident Report for Mastercard OB Services EU and UK

Monitoring

We are seeing signs of recovery and the service is serving traffic normally now.
Posted Aug 13, 2026 - 14:52 UTC

Identified

We are observing failures on the European Payment Platform. Payment flows are affected.
Posted Aug 13, 2026 - 14:15 UTC
This incident affects: Payment Products (Accept Payments).