High Payment Failure Volume: FI_Op

Incident Report for Mastercard OB Services EU and UK

Resolved

We see elevated rates of failed payments with many users affected on OP in Finland. OP has confirmed an issue on their side affecting payments in Finland. They are actively working on resolving the problem. We continue to monitor the situation closely.
Posted Jan 19, 2026 - 09:21 UTC

Identified

We see elevated rates of failed payments with many users affected on OP in Finland. OP has confirmed an issue on their side affecting payments in Finland. They are actively working on resolving the problem. We continue to monitor the situation closely.
Posted Jan 15, 2026 - 09:55 UTC

Update

We see elevated rates of failed payments with many users affected on OP in Finland.
Posted Jan 15, 2026 - 09:03 UTC

Investigating

more than 1,000 payments change status from “Preparing” to “Failed” within a one-hour window
Posted Jan 15, 2026 - 08:53 UTC