Observing issues with N26

Incident Report for Mastercard OB Services EU and UK

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 15:47 UTC

Investigating

We continue observing instabilities with N26, we are investigating further and monitoring the situation.
Posted Jul 27, 2026 - 10:35 UTC