Elevated failed payment rate with Nordea in Norway, Finland, Denmark and Sweden
Resolved
This incident has been resolved.
Posted Jan 23, 2025 - 09:57 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 22, 2025 - 14:21 UTC
Monitoring
We see elevated rates of failed payments with most users affected on Nordea and Nordea Yrityspankki in Norway, Finland, Denmark and Sweden.
Posted Jan 22, 2025 - 13:39 UTC