Elevated failed payment rate with Samlink based providers in Finland

Incident Report for Mastercard OB Services EU and UK

Resolved

We see elevated rates of failed payments with most users affected on Samlink based providers in Finland
Posted Mar 05, 2025 - 09:02 UTC

Identified

We see elevated rates of failed payments with most users affected on Samlink based providers in Finland
Posted Feb 27, 2025 - 13:16 UTC