Elevated payment error rates with Nordea Finland
Incident Report for Aiia
Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 10:38 UTC
Monitoring
Nordea Finland has instabilities in the Payment Initiation Service. We are monitoring it.
Posted Sep 19, 2022 - 07:30 UTC
This incident affected: Providers (Finland).