FI_Op elevated error rate

Incident Report for Mastercard OB Services EU and UK

Resolved

We are seeing elevated error rate for all AIS and PIS calls on FI_Op provider. We are monitoring the issue.
Posted Jun 09, 2026 - 08:18 UTC

Monitoring

We are seeing elevated error rate for all AIS and PIS calls on FI_Op provider. We are monitoring the issue.
Posted Jun 08, 2026 - 14:27 UTC