Elevated error rates with Nordea Finland
Incident Report for Aiia
Resolved
Nordea says that "The Payment Initiation Service is restored in all Nordics." and we also observe normal operations from around 00:15 today.
Posted Sep 17, 2022 - 09:11 UTC
Identified
We contacted the provider.
Posted Sep 16, 2022 - 11:11 UTC
Investigating
We have observed elevated error rates with Nordea Finland from 23:00 and currently investigating.
Posted Sep 16, 2022 - 05:56 UTC
This incident affected: Aiia (Aiia Pay) and Providers (Finland).